Attention: Please take a moment to consider our terms and conditions before posting.

***Electrical help***

Hi to any electrical appliance experts on here.  Looking for a bit of advice as late last night I spilt a glass of water near a plug socket and the splashes caused the circuit to trip out. After 1/2hour I managed to get it back on and everything seemed ok but this morning realised the main oven isn’t working. It’s a Beko twin oven and the top oven/grill works. Being one appliance I would assume it has a single mains connection so I’m a little confused. 
Any help much appreciated 

Comments

  • It should have a separate breaker in your consumer unit?  Are they all back on?
  • they’re all in the on position. Strange that the top oven works but the bottom one doesn’t 🤷🏻‍♂️
  • Was it on when you spilled the water?
  • Was it on when you spilled the water?
    No
  • As you say, I can't imagine each oven is on a separate circuit.
    It could just be a coincidence of course.
  • Check you have set the clock and the timer correctly on the main bottom oven, you would have lost power to these and if not set correctly the oven will not operate 
    You Sir are a ⭐️ 
    thanks very much!!!
  • Taxi_Lad said:
    Check you have set the clock and the timer correctly on the main bottom oven, you would have lost power to these and if not set correctly the oven will not operate 
    You Sir are a ⭐️ 
    thanks very much!!!
    No problem,  glad to be of help.
  • London Taxi drivers. The font of all knowledge :-)
Sign In or Register to comment.

Roland Out!